I can map the drive by IP but not name

The Other Options Didn’t Solve the Problem

When I had the problem of being able to see a shared drive on the file server only by using the IP address and not the name I began searching the internet for answers, some workstations would see it by name and some wouldn’t. There is a mixture of XP, Windows 7, and Windows 10 machines on the network and some of each different type would connect while others wouldn’t. When I searched the Internet I found solutions about going to ‘Credential Manager’ (Control Panel, Credential Manager, Windows Credentials) and removing the saved credentials and that seemed to solve the problem for a lot of people, but not for me.

Back Story / How I got in this Mess

The machine that the file server was on crashed. The drive was fine, but the system itself stopped working. After tracing it to the motherboard I knew there wasn’t going to be a quick fix. This is a small company and they only have one other machine that is used as the SQL server, there old machines, but were pretty good when they were purchased years ago. Anyway, I needed to get this drive up as soon as possible, so not having time to get a new machine and do a bare metal restore, I took down the SQL machine long enough to install the file server drive into it. Then installed Virtualbox, and having the virtual computer use the physical hard drive of the server computer. Whala (voila if your french), file server is back online inside the SQL server box. (They both had similar hardware that aided in making this possible).

As we move ahead in time a few weeks, I built a new machine and kept the old server drive as a virtual drive except converted the physical drive to an actual virtual drive. My thought here was that later I can virtualize both of them (file server and SQL server) and come up with a clustering solution spread over a couple physical machines. So, after putting it all together on a new machine and firing it up suddenly not all workstations see the shared folder on the file server. This is where the trauma begins…

The Solution

I used Windows 10 for the pictorial solution, but, if your familiar with things, just un-check IP version 6 from the list of protocols from the workstations that are having the problem and things should work for you too.

1. First, right click on you network taskbar icon

2. Then when the settings window opens select “Ethernet”

3. Next Select “Change Adapter Options”

4. On the next window “Right Click” on the “network adapter” and select “properties”

5. Next, Un-check the IP Version 6 protocol and select “OK”


You can’t make this stuff up. Anytime when you least expect it something will happen. I handled this with very little user disruption. Even when the server crashed, the time back up was under 3 hours and when the IPv6 problem happened it was intermittent and I could handle most of that over the weekend. Need expert help with your network? In the Dallas / Ft. Worth Area, call me. 972.571.4808.